読者です 読者をやめる 読者になる 読者になる

#untitled note

私的な考えとかメモ、その他トラブルシュート

BNRスピードテストで0kbpsになるのはAvira AntivirusのWebProtectionが原因だった

BNRスピードテスト

言わずと知れた回線速度計測サイト
BNR スピードテスト 回線速度/通信速度 測定

で、いつ頃からか計測状態が「........」と表示されて0kbpsの結果になったりしていたのだが
その原因がAviraAntivirusのWebProtectionにあることがやっとわかった。

どういう現象なのか?


こんな感じで、測定中のステータスは「.」もしくは少しだけ「O」がつくというような状態。
偶に回線速度が表示されるが、殆どの場合は画像のように「0kbps」で表示される。

回避方法は?

URL除外設定を追加するもしくはWebProtectionを無効にする。
どちらもセキュリティに関わる設定なので、これにより被害を被ったとしても私は責任を持ちません。

URL除外設定方法

  1. AntivirusProを開く
  2. 左にあるメニュー一覧からWeb Protectionを選択
  3. 右上にある[構成]を選択
  4. Web Protection -> スキャン -> 例外のようにツリーを開く
  5. 「Web Protectionのスキャン対象から除外するURL」に「.musen-lan.com」と入力*1
  6. OKボタンを押す。
これで完了。しかしこの方法、デメリットがあります。
デメリット
  1. .musen-lan.comドメインからの受信に対してWebProtectionが働かない。
  2. そもそもWebProtectionをONにしいてると「X」=「データ破棄」が多くなる
2番目の方は、まあWebProtectionを使うなら起こりうる問題なのかな、という感じですね。

WebProtection無効方法

ノーガード戦法。推奨できません。
  1. タスクトレイのAvira Antivirusのアイコン(赤傘アイコン)を右クリック
  2. Web Protection 有効にするをクリック(チェックを外す)

比較

真面目に比較しようかな。と思ったんだけれど面倒だな。って思って所感だけ。


  • 除外設定の場合:うまくDLできていても20Mbpsぐらい遅いっぽい?
    場合によっては正常に計測出来ているとは思えない値になることも。
  • 無効設定の場合:5回ぐらい試した結果間違いなく「X」は減るけど、やっぱり偶に「X」は出る。多分これは他の何かが原因。

速度を優先するか、安全性を優先するか各自で判断していけ。

そもそもなんでコレに気づいたのか

艦これが今、AviraAntivirusを起動しているだけで
アクセスするとCPU負荷が非常に高くなる現象が出ており、
またWebProtectionがONだとロードすら出来ないという状態になっています。

そうです。どうやら、AviraAntivirusとFlashPlayerの組み合わせがあまりよろしくないようなのです。

今まで、これは
  • FlashPlayerのバージョンアップが原因か?と思ってダウングレードしたり
  • ブラウザ依存か?と思って色々試したり、
  • 回線装置が壊れたか?と思って交換してもらったり
  • LANケーブルからモジュラージャックから全部取り替えたり
  • 挙句の果てにはプロバイダーも替えてみたり
したけど、結局変わらなかった。

しかし艦これの問題でより事態が深刻になって、初めてAviraという伏兵が居ることに気づいたのでした…。


Proユーザなので苦情を送りつけることにします。
改善されることはなさそうですけど。

*1:ドメイン指定除外